Hictop 3DP-08: Firmware not working properly

Software and Firmware Discussion - related to source code, firmware updates, etc.
ieatacid
Reactions:
Posts: 45
Joined: August 12th, 2017, 1:48 pm
Location: Scranton, PA
3D Printer(s): Hictop 3DP-03

Re: Hictop 3DP-08: Firmware not working properly

Post by ieatacid » August 13th, 2017, 12:18 am

My "Vxy-jerk" in the LCD menu says "20", which is the same as the lines that are commented out in configuration.h, if that's relevant.

User avatar
Roberts_Clif
Reactions:
Posts: 784
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Hictop 3DP-08: Firmware not working properly

Post by Roberts_Clif » August 13th, 2017, 12:32 am

Then you need to disable these lines
//#define FIX_MOUNTED_PROBE
//#define AUTO_BED_LEVELING_BILINEAR

And I would enable

//define this to enable EEPROM support
#define EEPROM_SETTINGS

This allows you to change your setting Using M502 and M500 and test without reflashing


Below this line "#define REPRAP_DISCOUNT_SMART_CONTROLLER // CL: Stock HICi3 20x4 LCD controller"
add
#define NEWPANEL // enable this if you have a click-encoder panel
Electronics Technician / Computer Programmer

User avatar
Roberts_Clif
Reactions:
Posts: 784
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Hictop 3DP-08: Firmware not working properly

Post by Roberts_Clif » August 13th, 2017, 12:35 am

Don't know if it makes much difference but I use 1 not 3 on these

* 1 : 100k thermistor - best choice for EPCOS 100k (4.7k pullup)
* 2 : 200k thermistor - ATC Semitec 204GT-2 (4.7k pullup)
* 3 : Mendel-parts thermistor (4.7k pullup)

#define TEMP_SENSOR_0 3
#define TEMP_SENSOR_1 0
#define TEMP_SENSOR_2 0
#define TEMP_SENSOR_3 0
#define TEMP_SENSOR_BED 3
Electronics Technician / Computer Programmer

User avatar
Roberts_Clif
Reactions:
Posts: 784
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Hictop 3DP-08: Firmware not working properly

Post by Roberts_Clif » August 13th, 2017, 12:37 am

Sorry error enable this
#define FIX_MOUNTED_PROBE
Electronics Technician / Computer Programmer

User avatar
Roberts_Clif
Reactions:
Posts: 784
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Hictop 3DP-08: Firmware not working properly

Post by Roberts_Clif » August 13th, 2017, 12:44 am

Here
Configuration.h
(56.05 KiB) Downloaded 117 times
Electronics Technician / Computer Programmer

ieatacid
Reactions:
Posts: 45
Joined: August 12th, 2017, 1:48 pm
Location: Scranton, PA
3D Printer(s): Hictop 3DP-03

Re: Hictop 3DP-08: Firmware not working properly

Post by ieatacid » August 13th, 2017, 12:44 am

My bed thermistor reads 108k ohms and the hot end reads 117k ohms. Should I use option 1?

User avatar
Roberts_Clif
Reactions:
Posts: 784
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Hictop 3DP-08: Firmware not working properly

Post by Roberts_Clif » August 13th, 2017, 12:46 am

ieatacid wrote:
August 13th, 2017, 12:18 am
My "Vxy-jerk" in the LCD menu says "20", which is the same as the lines that are commented out in configuration.h, if that's relevant.
They were changed to 5

And I did not see a difference when I changed them
Last edited by Roberts_Clif on August 13th, 2017, 12:47 am, edited 1 time in total.
Electronics Technician / Computer Programmer

ieatacid
Reactions:
Posts: 45
Joined: August 12th, 2017, 1:48 pm
Location: Scranton, PA
3D Printer(s): Hictop 3DP-03

Re: Hictop 3DP-08: Firmware not working properly

Post by ieatacid » August 13th, 2017, 12:46 am

Ok, I have your file now :)

User avatar
Roberts_Clif
Reactions:
Posts: 784
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Hictop 3DP-08: Firmware not working properly

Post by Roberts_Clif » August 13th, 2017, 12:50 am

ieatacid wrote:
August 13th, 2017, 12:44 am
My bed thermistor reads 108k ohms and the hot end reads 117k ohms. Should I use option 1?

I use option 1 and Have never had a problem.
Electronics Technician / Computer Programmer

User avatar
Roberts_Clif
Reactions:
Posts: 784
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Hictop 3DP-08: Firmware not working properly

Post by Roberts_Clif » August 13th, 2017, 12:58 am

You will need this
G code and M code master list
G code and M code master list.doc
(66 KiB) Downloaded 135 times

Original Firmware download, It would have been nice it they had the source code and not just the hex code.
https://www.hic3dprinter.com/pages/firmware
Last edited by Roberts_Clif on August 13th, 2017, 1:06 am, edited 1 time in total.
Electronics Technician / Computer Programmer

ieatacid
Reactions:
Posts: 45
Joined: August 12th, 2017, 1:48 pm
Location: Scranton, PA
3D Printer(s): Hictop 3DP-03

Re: Hictop 3DP-08: Firmware not working properly

Post by ieatacid » August 13th, 2017, 1:05 am

With you so far.

User avatar
Roberts_Clif
Reactions:
Posts: 784
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Hictop 3DP-08: Firmware not working properly

Post by Roberts_Clif » August 13th, 2017, 1:13 am

That about it.

Except printing a 20x20mm test block, and remembering where your firmware backup can be downloaded.
Last edited by Roberts_Clif on August 13th, 2017, 1:16 am, edited 1 time in total.
Electronics Technician / Computer Programmer

ieatacid
Reactions:
Posts: 45
Joined: August 12th, 2017, 1:48 pm
Location: Scranton, PA
3D Printer(s): Hictop 3DP-03

Re: Hictop 3DP-08: Firmware not working properly

Post by ieatacid » August 13th, 2017, 1:15 am

What programmer do I select in the Arduino IDE? And then I just build and upload it?

User avatar
Roberts_Clif
Reactions:
Posts: 784
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Hictop 3DP-08: Firmware not working properly

Post by Roberts_Clif » August 13th, 2017, 1:19 am

Arduino/Genuino Mega or Mega 2560

Processor

ATmega2560(Mega 2560)

Then of course the Port
Electronics Technician / Computer Programmer

ieatacid
Reactions:
Posts: 45
Joined: August 12th, 2017, 1:48 pm
Location: Scranton, PA
3D Printer(s): Hictop 3DP-03

Re: Hictop 3DP-08: Firmware not working properly

Post by ieatacid » August 13th, 2017, 1:25 am

What do you have selected in the menu Tools->Programmer (below "Get Board Info")?

Post Reply

Return to “Software and Firmware Discussion”