Problem with Heatbed Assembly for Tevo Tarantula

Discussion of ANY 3D printing topic you desire!
Post Reply
kuhn5434
Reactions:
Posts: 1
Joined: March 11th, 2019, 3:22 pm
3D Printer(s): Tevo Tarantula

Problem with Heatbed Assembly for Tevo Tarantula

Post by kuhn5434 » March 11th, 2019, 3:47 pm

Hello all,
I have been constructing my Tevo Tarantula but got stuck when I needed to mount the heatbed. In videos I see it is already put together, however my foil insulation sticky pad is not on the Tevo tarantula logo heat bed. Do I need to wire anything to the heatbed or do I just attach the sticky insulation pad? Please see attached photo.

Thanks,
Kevin
Attachments
98D106AD-912E-42FA-B6F0-2235C07BBFEA.jpeg
Image of heatbed and insulation pad

User avatar
Roberts_Clif
Reactions:
Posts: 722
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Problem with Heatbed Assembly for Tevo Tarantula

Post by Roberts_Clif » April 4th, 2019, 8:15 am

Hello and welcome to the 3D Printing forum.

I see that you posted and somehow got lost, Reply to my post we will see if there is something we can do to correct they oversight.

Clif
Electronics Technician / Computer Programmer

GrueMaster
Reactions:
Posts: 414
Joined: March 15th, 2017, 8:46 pm
Location: Oregon
3D Printer(s): Hictop 3DP-17, Hictop CR-10S

Re: Problem with Heatbed Assembly for Tevo Tarantula

Post by GrueMaster » April 4th, 2019, 9:58 am

I know @LePaul has one. Maybe he can help.

User avatar
LePaul
Reactions:
Posts: 3341
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): UM2+,CR-10S (x2),Tevo Tornado,FT-i3/FT-5/FT-6...
Contact:

Re: Problem with Heatbed Assembly for Tevo Tarantula

Post by LePaul » April 4th, 2019, 1:46 pm

GrueMaster wrote:
April 4th, 2019, 9:58 am
I know @LePaul has one. Maybe he can help.
I have a Tevo Tornado

Post Reply

Return to “General 3D Printing Conversation”