Broken PWM on Ultiboard v2

Discussions concerning the Ultimaker 2 / Ultimaker 2+ series of printers, including the Ultimaker 2 Go
Post Reply
User avatar
nicoco007
Reactions:
Posts: 3
Joined: December 16th, 2017, 7:31 pm
3D Printer(s): Prusa i3

Broken PWM on Ultiboard v2

Post by nicoco007 » December 16th, 2017, 7:54 pm

I've been working with a few Ultimaker 2+ printers lately and I just noticed that it is impossible to change the brightness of the LEDs and/or control the side cooling fans on some of them. I know that on one of the printers the LEDs were shorted before this issue appeared, and on another one the fans were shorted, so I'm guessing something on the board was fried. This was confirmed when I swapped the broken board for one from a working machine, and both the fans and the LEDs worked.

I did a bit of research, and it looks like it is most likely the PWM circuit's transistor that was fried on these boards. According to this document (page 8, bottom left corner), those are BC817 transistors. However, I have looked at them on the boards in question and they don't seem to be damaged in any way.

Would it make sense to replace these transistors, or is this issue caused by something else altogether? We'd rather not spend hundreds of dollars on new boards if it's just a tiny part of the board that is broken.

User avatar
Neotko
Reactions:
Posts: 1142
Joined: February 7th, 2016, 7:02 pm
Location: Madrid
3D Printer(s): UMO+ x2.5
Contact:

Re: Broken PWM on Ultiboard v2

Post by Neotko » December 17th, 2017, 9:08 am

I broke my bc817 8 times, first time I did pay a professional to change the transistor. But the sexond to 8th time I did it learning how to solder stuff and with kapton tape, air desolder and patience.

https://ultimaker.com/en/community/1721 ... not-solved

User avatar
nicoco007
Reactions:
Posts: 3
Joined: December 16th, 2017, 7:31 pm
3D Printer(s): Prusa i3

Re: Broken PWM on Ultiboard v2

Post by nicoco007 » December 17th, 2017, 4:23 pm

I took a look at that thread and attempted swapping one of the broken transistors with one from a board I knew was good, and it worked! Thanks!

I decided to buy a bunch of them off DigiKey; hopefully they'll work. I'll post an update once I receive them.

User avatar
jonnybischof
Reactions:
Posts: 310
Joined: February 15th, 2016, 2:48 am
Location: Zurich, Switzerland
3D Printer(s): UMO

Re: Broken PWM on Ultiboard v2

Post by jonnybischof » December 18th, 2017, 3:13 am

Yup, those transistors have 0 chance of surviving a short circuit :)
Fine example of "maker electronics".
Best regards,
Jonny

User avatar
nicoco007
Reactions:
Posts: 3
Joined: December 16th, 2017, 7:31 pm
3D Printer(s): Prusa i3

Re: Broken PWM on Ultiboard v2

Post by nicoco007 » December 21st, 2017, 7:03 pm

jonnybischof wrote:
December 18th, 2017, 3:13 am
Yup, those transistors have 0 chance of surviving a short circuit :)
Fine example of "maker electronics".
Yep. Just replaced all of them and they work. It's a bit annoying that this happens considering the fans are one of the easiest things to short circuit...

Anyway, for anyone living in Canada or the US, I can confirm that these transistors from DigiKey work perfectly.

Thanks for your help guys!

Post Reply

Return to “Ultimaker 2 / Ultimaker 2+ / Extended & Go”

Who is online

Users browsing this forum: No registered users and 6 guests