Z homes move 70mm after home...

Discussion of the Ultimaker Original and Ultimaker Original + (kit and pre-assembled) printers
Post Reply
User avatar
Neotko
Reactions:
Posts: 1142
Joined: February 7th, 2016, 7:02 pm
Location: Madrid
3D Printer(s): UMO+ x2.5
Contact:

Z homes move 70mm after home...

Post by Neotko » March 16th, 2016, 10:37 am

Hi I finishing tunning my third umo+ that has all the good stuff, except the board that's from china.

So my franken umo+ does home perfect but when it moves 1mm it thinks the 0 home it's at 70mm!

It's this something from um2 firmware?

I flashed it with amedee builder and esteps and all steps move perfect but it does this

User avatar
Neotko
Reactions:
Posts: 1142
Joined: February 7th, 2016, 7:02 pm
Location: Madrid
3D Printer(s): UMO+ x2.5
Contact:

Re: Z homes move 70mm after home...

Post by Neotko » March 16th, 2016, 10:45 am

Solved, connected by printrun/pronterface and got an Echo M206 that did had Z-70mm solved it by doing M206 Z0
hurray =)

Nothing like writing the stuff to find the sollution

User avatar
LePaul
Reactions:
Posts: 3123
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: Z homes move 70mm after home...

Post by LePaul » March 16th, 2016, 10:46 am

I'm not sure what that answer is in the Queen's English....but weird for sure

User avatar
Amedee
Reactions:
Posts: 599
Joined: February 15th, 2016, 11:10 am
Location: Brussels, Belgium
3D Printer(s): UMO / UMO+
Contact:

Re: Z homes move 70mm after home...

Post by Amedee » March 16th, 2016, 10:56 am

To be sure, can you 'reset' NVRAM?
Phil.

User avatar
Amedee
Reactions:
Posts: 599
Joined: February 15th, 2016, 11:10 am
Location: Brussels, Belgium
3D Printer(s): UMO / UMO+
Contact:

Re: Z homes move 70mm after home...

Post by Amedee » March 16th, 2016, 10:57 am

Ooops -- too late ;)

But I think it was the problem: some leftovers in the NVRAM...
Phil.

User avatar
Neotko
Reactions:
Posts: 1142
Joined: February 7th, 2016, 7:02 pm
Location: Madrid
3D Printer(s): UMO+ x2.5
Contact:

Re: Z homes move 70mm after home...

Post by Neotko » March 16th, 2016, 11:49 am

Indeed that sounds like it. Weird I didnt knew that um2 needs a 70 offset from the endstop

User avatar
Neotko
Reactions:
Posts: 1142
Joined: February 7th, 2016, 7:02 pm
Location: Madrid
3D Printer(s): UMO+ x2.5
Contact:

Re: Z homes move 70mm after home...

Post by Neotko » March 16th, 2016, 11:59 am

Amedee wrote:To be sure, can you 'reset' NVRAM?
Hey amedee it's there anyway to read the nvram of the board to see how many hours I have used a printer? I know um2 has that, but on umo+ I never found out if was posible... Sorry just a random thought :D

User avatar
Amedee
Reactions:
Posts: 599
Joined: February 15th, 2016, 11:10 am
Location: Brussels, Belgium
3D Printer(s): UMO / UMO+
Contact:

Re: Z homes move 70mm after home...

Post by Amedee » March 16th, 2016, 1:11 pm

It is an UM2 feature, not a Marlin Original one ;)

It is something we could relatively easily do (most probably only for SD-Card jobs as I still can't figure out how to detect properly end of USB print jobs)
Phil.

User avatar
Neotko
Reactions:
Posts: 1142
Joined: February 7th, 2016, 7:02 pm
Location: Madrid
3D Printer(s): UMO+ x2.5
Contact:

Re: Z homes move 70mm after home...

Post by Neotko » March 16th, 2016, 2:41 pm

That could be fun to have!

Post Reply

Return to “Ultimaker Original & Ultimaker Original +”

Who is online

Users browsing this forum: No registered users and 1 guest