Marlin 1.1.5

Software and Firmware Discussion - related to source code, firmware updates, etc.
Post Reply
User avatar
Roberts_Clif
Reactions:
Posts: 322
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Marlin 1.1.5

Post by Roberts_Clif » September 3rd, 2017, 6:22 pm

Upgraded again from Marlin 1.1.4 to Marlin 1.1.5 was hoping that they had fixed, the problem that after It Auto homes while displaying CUSTOM_MACHINE_NAME Z-axis will rise changing the display to " Endstops Z " or "G28 Z Forbidden"

Problem still exists See Marlin 1.1.4 this Forum.

User avatar
Roberts_Clif
Reactions:
Posts: 322
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Marlin 1.1.5

Post by Roberts_Clif » September 7th, 2017, 2:46 pm

Today I decide to re-flash Marlin 1.1.5 on both 3D Printers 3DP11/3DP12 Upgraded about every thing can use with the printers.

Red flashed perfect and is running without error, Blue is giving me fits still only displaying the " Endstops Z " but works perfect in all other ways,
and only gives the Error during the Auto home

User avatar
Roberts_Clif
Reactions:
Posts: 322
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Marlin 1.1.5

Post by Roberts_Clif » September 8th, 2017, 5:18 pm

I replaced the Controller board with my Brand new Controller that I purchased just so I would not ever Be down.
I when I tried to Print my good old friend returned "MIN TEMP ERROR" started trouble shooting and every thing on the accessories tested Ok.
So started looking over the firmware nothing wrong there, it is working in the other machine.
Replaced the controller again so I could get a better look see.

And come to find that is has a faulty trace leading to the Hot End thermister. It was almost completely covered with the silkscreen,
looking carefully and all you could see was a little wave over the trace leading to the Hot end thermister connector.
While working in manufacturing as a quality control Electronics Technician, I recognized this instantly as a defective trace.

Using a Eurotool fiberglass cleaning brush erased the silkscreen from above the broken trace an bridged solder across the trace gap.
If I was still a QC Technician would a dabbed on a little silkscreen background color and returned to the assembly line.

Looking closely you can see that even the ground plane around the eaten trace has rough edges caused by the etching process.
No problems fixed now and already has Marlin 1.1.5 Firmware installed, so it's back to the replacement parts bin .

Image1.jpg
Last edited by Roberts_Clif on October 1st, 2017, 10:17 am, edited 1 time in total.

User avatar
Roberts_Clif
Reactions:
Posts: 322
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Marlin 1.1.5

Post by Roberts_Clif » September 9th, 2017, 11:17 am

Here is the latest testing results.

Raise bed to 100mm and Auto home, after the X and Y Axis home we single tap the Z-Proximity sensor with a metal putty knife simulating the bed.
It will detect what it believes is bed rise 10mm then drop down again to what it believes is Z-Axis zero, once more will rise to Z_CLEARANCE_DEPLOY_PROBE 10 this time it has no display to " Endstops Z " error.

Have done this dozens of times with no " Endstops Z " error, as soon a it detects the bed the second time I get the Error Again.
Help

User avatar
Roberts_Clif
Reactions:
Posts: 322
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Marlin 1.1.5

Post by Roberts_Clif » September 10th, 2017, 2:12 pm

I reverted to the Previous version of Marlin-RC8BF-HICi3 it works Perfectly.

Marlin 1.1.5 using M500 causes CRC errors.

User avatar
Roberts_Clif
Reactions:
Posts: 322
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Marlin 1.1.5

Post by Roberts_Clif » September 17th, 2017, 9:17 am

Not an error, looks like it is just a checksum that is stored with the data for testing.

configuration_store.cpp

// Report storage size
#if ENABLED(EEPROM_CHITCHAT)
SERIAL_ECHO_START();
SERIAL_ECHOPAIR("Settings Stored (", eeprom_size - (EEPROM_OFFSET));
SERIAL_ECHOPAIR(" bytes; crc ", (uint32_t)final_crc);
SERIAL_ECHOLNPGM(")");
#endif
------------------------------------------------------
#define EEPROM_WRITE(VAR) write_data(eeprom_index, (uint8_t*)&VAR, sizeof(VAR), &working_crc)
#define EEPROM_READ(VAR) read_data(eeprom_index, (uint8_t*)&VAR, sizeof(VAR), &working_crc)
------------------------------------------------------
const uint16_t final_crc = working_crc;

User avatar
LePaul
Reactions:
Posts: 2971
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: Marlin 1.1.5

Post by LePaul » September 17th, 2017, 11:17 am

Have you done any testing with the Linear Advance they have added in newer builds?

User avatar
Roberts_Clif
Reactions:
Posts: 322
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Marlin 1.1.5

Post by Roberts_Clif » September 17th, 2017, 3:13 pm

LePaul wrote:
September 17th, 2017, 11:17 am
Have you done any testing with the Linear Advance they have added in newer builds?
Not as of this date, was looking into the CRC error if it was going to crash the into the bed causing damage.
Have been helping the the forums New users get setup with their new Printers to kill time.
And Building a Printer enclosure to filter out the smells 3D printing makes the little woman doesn't like the smells.
Therefore can not print until I remove the smells.

Took a quick look at Linear Advance and will implement after the Enclosure is finished.

Would like to know why display " Endstops Z " only when home of any kind is preformed. during raising to Z Clearance probe Deploy/Stow height.
However I have a fixed mounted Proximity sensor.

GrueMaster
Reactions:
Posts: 262
Joined: March 15th, 2017, 8:46 pm
Location: Oregon
3D Printer(s): HICTOP 3DP-17

Re: Marlin 1.1.5

Post by GrueMaster » September 30th, 2017, 1:30 pm

Did you post your Configuration*.h files somewhere? I'd like to update my 3DP-17 (~1.1.0-RC8 ish) without going through all of the needed changes (again).

User avatar
Roberts_Clif
Reactions:
Posts: 322
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Marlin 1.1.5

Post by Roberts_Clif » September 30th, 2017, 3:50 pm

GrueMaster wrote:
September 30th, 2017, 1:30 pm
Did you post your Configuration*.h files somewhere? I'd like to update my 3DP-17 (~1.1.0-RC8 ish) without going through all of the needed changes (again).

User avatar
Roberts_Clif
Reactions:
Posts: 322
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: Marlin 1.1.5

Post by Roberts_Clif » October 16th, 2017, 9:41 am

At this point I have re-flashed Marlin 1.1.5 too many times to count, and have made only minuscule changes, and had but forgotten about this problem.
Until I ran across this line of code " #define Z_HOME_BUMP_MM 2"
Roberts_Clif wrote: Marlin 1.1.5 after Auto home while displaying CUSTOM_MACHINE_NAME Z-axis will rise changing the display to " Endstops Z " or "G28 Z Forbidden"
Well I have no explanation, thou it has stopped displaying. I believe that in the following line of code lies the solution thou.

#define Z_HOME_BUMP_MM 5 // changing from 2 to 5 would raise the z_home Bump above the Z probe sensor level thereby eliminating the errors.

Post Reply

Return to “Software and Firmware Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests