Serious Issues

Software and Firmware Discussion - related to source code, firmware updates, etc.
Post Reply
hedijas10
Reactions:
Posts: 3
Joined: December 31st, 2016, 7:20 pm
3D Printer(s): Hictop Prusa i3

Serious Issues

Post by hedijas10 » December 31st, 2016, 7:41 pm

Hey guys,

So I finished assembling my Hictop Reprap Prusa I3 MK8, and it seemed to almost work for a time. The LCD was working, although even after installing all of the drivers, Cura was unable to connected to the printer. The main issue that started this entire process was that I was not able to control the filament motor through the LCD menu. I tried a test print with a SD card, and the printer just sort of splooged plastic out wherever it felt like it, but that is not my main concern at the moment.

My first reaction was to update the firmware, so I tried that using Arduino and the Marlin firmware. Since then my LCD has just been blank. I have been unable to get anything to show up on the screen regardless of what firmware I have tried using.

More recently, I tried using Repetier to connect to the printer. It seemed to connect to the printer sort of. When I tried to control the print head using the software, the print head just smashed into the bed and left a huge indentation. Im sure that the extruder is damaged now, but that is not my concern at the moment either.

So what do I do from here? I dont think that my motherboard is damaged, but then again I seem to have no idea what the hell I am talking about. Where is a starting point for me so that I can get this printer working again? ANY suggestions would be much appreciated. I've browsed the forums and tried everything I can think of.

Thanks,

rcabor
Reactions:
Posts: 11
Joined: June 10th, 2016, 8:38 am

Re: Serious Issues

Post by rcabor » January 1st, 2017, 9:08 am

The marlin firmware from github must be modified to work correctly with your printer. More than likely, the inital problem was you calibration was not set right. Now you need to get the right firmware before you can go any further. What model do you have?

hedijas10
Reactions:
Posts: 3
Joined: December 31st, 2016, 7:20 pm
3D Printer(s): Hictop Prusa i3

Re: Serious Issues

Post by hedijas10 » January 1st, 2017, 3:01 pm

The model is a 3DP-18 and the control board chip is a atmega2560, integrated board of ramps1.4

rcabor
Reactions:
Posts: 11
Joined: June 10th, 2016, 8:38 am

Re: Serious Issues

Post by rcabor » January 1st, 2017, 3:29 pm

click here

Thats a link to a thread that has the original firmware as well has some hints on where to begin. You have the same printer as me, but I have updated the firmware to add the autolevel sensor. This printer prints really well after you get it setup and calibrated. Good Luck and feel free to ask for help!

hedijas10
Reactions:
Posts: 3
Joined: December 31st, 2016, 7:20 pm
3D Printer(s): Hictop Prusa i3

Re: Serious Issues

Post by hedijas10 » January 1st, 2017, 4:39 pm

Thanks for the response, I appreciate the help!

Moved to a new computer because I kept timing out and installed the factory firmware from then forum link you sent me. Seems to be working ok!

Post Reply

Return to “Software and Firmware Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests