Mendel inductive sensor z-probe

Software and Firmware Discussion - related to source code, firmware updates, etc.
Post Reply
morris4019
Reactions:
Posts: 2
Joined: August 7th, 2016, 1:21 am
3D Printer(s): HICTOP Prusa i3

Mendel inductive sensor z-probe

Post by morris4019 » August 7th, 2016, 8:30 pm

I am having some issues installing an inductive sensor as my z-endstop (eventually auto bed leveling turned on)-but I seem to be having issues with firmware.

I have the Red MPX.3 board (HICTOP Prusa i3 Black Acrylic kit). I have a LJ18A3-8-Z/BX (Orange Tip, 8mm sensing distance) wired up with voltage divider and have tested the input/output. Input voltage is hooked to 12v, output divided and sending ~4.59v through the signal wire. The sensor properly sends 4.59v while not triggered, and then 0v while triggered. I have tested the signal wire on all three pins since this board doesn't have the markings for "+-s", with no change on either pin. I CAN, however, re-plug my mechanical endstop switch back in and everything works fine-it just seems that the firmware is not responding to the 5v->0v triggering sensor.

I have attached the firmware that I am currently using if anyone could please help me figure out my issue.
Attachments
Marlin_HICi3-1.1.03-RC4_CL041816A 2.zip
(608.33 KiB) Downloaded 68 times

mpoling
Reactions:
Posts: 15
Joined: August 12th, 2016, 11:31 am
3D Printer(s): HICTOP Prusa i3 3DP17

Re: Mendel inductive sensor z-probe

Post by mpoling » August 13th, 2016, 12:50 pm

I found a problem as well...I carved a good chunk out of my heated bed plate trying to get that sensor to work. What I found out was that the mount is too high above the extruder head. I SAYS 8 mm but if you check, it's more like 4 mm to trigger the sensor. I took the sensor off and mounted it lower with a zip tie for now, and it works fine. Now I have to figure out how to mount it properly so it doesn't slip, but still be removable if I change nozzle sizes.

mpoling
Reactions:
Posts: 15
Joined: August 12th, 2016, 11:31 am
3D Printer(s): HICTOP Prusa i3 3DP17

Re: Mendel inductive sensor z-probe

Post by mpoling » August 13th, 2016, 12:51 pm

What is the benefit of the inductive sensor anyway? The mechanical sensor seems to do exactly the same thing, but without the problems...any reason we need the inductive one?

User avatar
Chip Luck
Reactions:
Posts: 191
Joined: February 11th, 2016, 9:12 am
Location: Central Florida
3D Printer(s): HICTOP Reprap Prusa I3
Contact:

Re: Mendel inductive sensor z-probe

Post by Chip Luck » August 15th, 2016, 11:26 am

mpoling wrote:What is the benefit of the inductive sensor anyway? The mechanical sensor seems to do exactly the same thing, but without the problems...any reason we need the inductive one?
So called auto-bed-leveling probing software,option with various probe grid/point probing is one reason. I can only use inductive, mechanical side rail z-switches fail and wear out, I had a nozzle to bed crash a few times with cheap mechanical z-height switches. If use a glass bed, mechanical is the only option for now.

KevinA
Reactions:
Posts: 4
Joined: August 2nd, 2016, 6:17 pm
3D Printer(s): MKS GEN 1.4 / HICTOP

Re: Mendel inductive sensor z-probe

Post by KevinA » August 25th, 2016, 4:40 pm

I've been working on my 3DP11 for awhile waiting on replacement parts; Limit Switch bad, Z axis screws bent, extruder with wrong parts. This is how I'm mounting mine (see pictures) but no matter where you mount it, it goes off the work area. I have been trying to get them to send the configuration.h file but they seem to think Open Source means something I don't understand. I have a MKS Base 1.3 controller which again, I have been trying to get the pin outs and what they set the stepper drivers to for step size, they just flat out told me they are not open source.
I spent some time tweaking the screws that came with this machine as I wait on the lead screw setup I paid them for as an upgrade just to find out they shipped 4 step lead screws. The machine works but makes bad sounds when moving around manually with the control panel. In the pictures I haven't ran the sensor wire into the cable run yet.
A few hours later: I adjusted the X axis to be equal then adjusted the the bed and then lowered the inductive probe until it triggered. The result is a new probe NO+NC LJ18A3-8-Z/CY Inductive Proximity Sensor - My existing probes: LJ12A3-4-Z/BX and LJ12A3-4-Z/BY just became pet rocks.
1. The black SIGNAL wire shows 0 volts until triggered and then it is 5 volt. The 3DP11 is pulled up to 5 volts until the limit switch closes then it is 0 volts.
2. That 4mm sensor is from China is really 1.4mm which is the thickness of the material over my bed before I add masking tape!
Attachments
sideview.jpg
Looking at the clearance
top.jpg
I could have moved it a little closer
front.jpg
I have some tweaking left to do
side.jpg
The bend was to stiffen the mount

User avatar
Chaco
Reactions:
Posts: 41
Joined: September 12th, 2016, 6:48 pm
Location: OH
3D Printer(s): HyperCube & Hictop Prusa i3 3DP-08
Contact:

Re: Mendel inductive sensor z-probe

Post by Chaco » September 14th, 2016, 10:55 am

Hello folks. Newbie here. Thank you for having a nice place to learn about these printers. I have the the 3DP_08 version

I was trying to use the SN04 hic sells but couldn't get it to trigger with stock bracket without having tip touch bed.
So I printed the thingiverse adjustable adapter and while I can make it trigger now, I really hate it's position. It's like 70mm away from hot end. Not very ideal since it would be in air for the rear 1/3 of the bed and like in the middle of bed when the hot end is on front.
What's everyone's preferred location for inductive sensor?
Should I just return the sensor and try something else? Should I position it somewhere else closer (by fan) or should i try getting one of them skinny sensors as shown above? I'm having a hard time trying to come up with a practical location for these sensor. My bed is about .1mm lower on the center than the perimeter hence why I wanted this sensor. (Been printing on glass bc of it)

marknemo2000
Reactions:
Posts: 5
Joined: September 7th, 2016, 6:14 pm
3D Printer(s): hictop aluminum

Re: Mendel inductive sensor z-probe

Post by marknemo2000 » September 22nd, 2016, 2:54 pm

Where do you hook up the sensor 3dp-11, and what software do I need?

User avatar
Chaco
Reactions:
Posts: 41
Joined: September 12th, 2016, 6:48 pm
Location: OH
3D Printer(s): HyperCube & Hictop Prusa i3 3DP-08
Contact:

Re: Mendel inductive sensor z-probe

Post by Chaco » September 24th, 2016, 10:48 pm

marknemo on my hictop u have to replace the switch with the sensor. So it uses the same plug on the motherboard. The firmware on the motherboard does need to be updated. HICTOP gave me one, that works fine, but i can tell accelerations are super high

I took Chip's and edited it to make it work on mines. but i am not using the sensor still since i want to figure out how to best set it closest to the hot end, since i dont like the fact it so far away.

Post Reply

Return to “Software and Firmware Discussion”

Who is online

Users browsing this forum: No registered users and 2 guests