Page 3 of 5

Re: Firmware Marlin-1.1.0-RC6 - now running

Posted: January 9th, 2017, 11:01 am
by RyanE
boomhaeur wrote:
Hey Chip,

Having the same issue... from my measurements I have the 8mm x 1.25mm threaded rod (what came with the kit) which would require 2560. I've adjusted it to the correct number (and even taken it up as high as 4000), and it seems to make no difference, I still have about a 3-4mm gap between the bed and the nozzle.

Am I missing something? Is there another variable I should be adjusting or possible issue afoot?

I have the auto-level version if that makes any difference & the nozzle level was functioning correctly on the stock firmware when I first set it up. It auto homes fine and has the right height of the bed when auto-homed.

Appreciate any thoughts you might have.
boomhaeur: Take a look at the #define Z_PROBE_OFFSET_FROM_EXTRUDER value. It will vary based on how far above your extruder your sensor is mounted. Mine is currently set to -0.7 based on my setup.

I have noticed, though, that the sensor that comes with the 3DP12 does vary by a few tenths of a mm, which is not good. I am wondering if it is due to the fact that the sensor is only powered by a 5V source when the datasheet lists the minimum voltage as 6V. Has anyone tried hooking the sensor up to 12v/24V and using a voltage divider on the output to get it back to 5V? I had a capacitive sensor on my last printer that was powered by 12V and it was much more accurate.


Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: January 10th, 2017, 2:38 pm
by boomhaeur
Thanks... have played with the setting (between -5 & +5) and doesn't seem to make any difference.

I'm wondering if I've missed something when trying to enable the auto-levelling in the script. (it's not even going down to the point where the light kicks on for it)

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: January 10th, 2017, 3:23 pm
by boomhaeur
Actually RyanE you were on the right track... I'd missed un-commenting a couple of lines in the auto-leveling section and once I did that your suggestion seems to have started taking effect although now I think I've got a z-axis calibration issue as 1mm seems to move almost a cm on each increment.

Update: I have no idea why but my stock threaded rod/motor combination wanted ~350 as a steps/mm. As soon as I dialed that in, then got the auto-level functions set right things started working just right. SD card was giving me some grief but printing from USB via Pronterface has things coming out beautifully.

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: January 30th, 2017, 6:58 pm
by IronKane
First off, thank you Chip. Having compilable firmware for my Hictop 3DP-17 is a life saver.

I am another one with a whacked out Z steps per unit. It's like it's using CM instead of MM. I set it to 400 and uploaded it and it was close. It was dragging through the previous layer now a little bit, but it was way better than being several mm above the bed. Setting the steps for Z to 450 seems to have it dialed in. I would set my zero and using my dial calipers as a depth gauge, I noted the distance between the bed and the top of the extruder stepper. I then sent a G1 Z0.35, measured the new gap and subtracted the difference. I was able to get it to within 0.03mm.

This is great, but it's WAY too illogical!!! It should be around the 2560 value, not a 2,110 step difference! Is there some other parameter/variable that could account for this weird discrepancy?

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: April 12th, 2017, 5:16 pm
by Dan365
Hictop 3DP-17 does anyone have a zip file of source with leveling enabled so I can load it up please.
secondly has thermal runaway been solved on pla?
does it print okay without introducing other issues?

just I'm happy compiling- just less sure on other steps.

thank you

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: April 13th, 2017, 4:40 pm
by Dan365
As a side note I fixed hictop steps on encoder LCD etc on previous version, but this version doesn't work well for me so far

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: May 25th, 2017, 1:12 am
by shock72
* edit* got it sorted out, i guess it decided not to compile because it's thursday or if i can just get the nozzle to bed gap issue fixed i'll be good to go.

trying to complile the code in arduino to upload but I keep getting "exit status 1 missing binary operator before token "(" in the conditionals.h tab
right at the

Code: Select all

any ideas how to get it working properly? the firmware is straight from the download file with no mods.

also another issue and the reason i was starting with the fresh code, I had previously flashed the board with CL's version (complied with no issues before) and everything was working well except the nozzle to bed gap would be off a few mm at the start of the print. Manual bed level, it's set to the correct gap when it homes but when it starts the print it doesn't lower the nozzle to the proper gap. Pretty new to printing and so so with code but i'm not sure what i need to adjust in the config. only other solution is setting a z offset in the slicer. I tried printing with Cura, tried it in repetier , same issue.

Re: Firmware Marlin-1.1.0-RC6 - now running

Posted: August 17th, 2017, 4:35 pm
by Roberts_Clif
rellik1000 wrote:
August 4th, 2016, 9:13 pm
M303 E0 S200 C8 used to obtain auto tune values.

After a second look it does appear to vary closer to 1-2 degrees after 20 min or so using Ultimaker values.
The auto values never even make it that far and return "thermal runaway"after about 10 min or so.

I never had to mess with the PID values with my first printer it just worked.
After I did PID Auto Tune Nozzle and Hotbed, And entering numbers into Configuration.h file, I Get Thermal runaway.
Could I get a thermal runaway if i did not do a M502 and M500, before printing. Reverted back to Original Marlin Using Ultimaker PID Nozzle settings.
Disabled Bed PID back to Bang Bang Bed Heating.

Or is it just I can not do PID On my Hictop 3DP11 Aluminum hotbed.

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: October 10th, 2017, 7:14 pm
by syadnom
I'm able to flash a hictop i3 mk8 (plexi frame) with the MPX.3 board. This has caused the board to stop working, no LCD and if I try to move the axis around it says endstops are hit. Anyone else run into this and/or have a solution?

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: October 10th, 2017, 8:38 pm
by Roberts_Clif
Hictop original hex files are here

Will take a look if you Attach the Configuration.h

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: October 10th, 2017, 11:32 pm
by syadnom
This is a fresh download of 1.1.6, and the only alterations are the xyze defaults.

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: October 10th, 2017, 11:38 pm
by syadnom
some more info just in case it's relevant.

Using freshly installed arduino ide 1.8.5, selecting Arduino mega 2560 as the device, programmer is the AVRISP mkii, opening the marlin 1.1.x ( which is 1.1.6) file that was freshly downloaded, making the alterations to the accel and steps, and uploading.

Also, I have tried to flash the hic hex file back with XLoader but it doesn't complete. Any other recommended method to take it back to stock?

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: October 10th, 2017, 11:41 pm
by syadnom
after the upload, arduino ide says 'done uploading', using 52292 bytes, and the serial console output is when I hit the reset button is:
echo:Marlin 1.1.6

echo: Last Updated: 2017-10-10 12:00 | Author: (none, default config)
echo:Compiled: Oct 10 2017
echo: Free Memory: 5572 PlannerBufferBytes: 1232
echo:Hardcoded Default Settings Loaded
echo: G21 ; Units in mm

echo:Filament settings: Disabled
echo: M200 D3.00
echo: M200 D0
echo:Steps per unit:
echo: M92 X80.00 Y80.00 Z398.00 E94.40
echo:Maximum feedrates (units/s):
echo: M203 X500.00 Y500.00 Z5.00 E25.00
echo:Maximum Acceleration (units/s2):
echo: M201 X3000 Y3000 Z100 E10000
echo:Acceleration (units/s2): P<print_accel> R<retract_accel> T<travel_accel>
echo: M204 P3000.00 R3000.00 T3000.00
echo:Advanced: S<min_feedrate> T<min_travel_feedrate> B<min_segment_time_ms> X<max_xy_jerk> Z<max_z_jerk> E<max_e_jerk>
echo: M205 S0.00 T0.00 B20000 X20.00 Y20.00 Z0.40 E5.00
echo:Home offset:
echo: M206 X0.00 Y0.00 Z0.00
echo:PID settings:
echo: M301 P22.20 I1.08 D114.00

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: October 11th, 2017, 9:32 am
by Roberts_Clif
Have never used XLoader.

I see in your configuration.h file you may have flashed the Board to 250000. Hictops boards do not like this baudrate.
Though now that you have set it to 250000 you will have to use this baudrate until you re-Flash to a different baudrate.

Baudrate is set to 115200 and have supplied you with same file I have to several others making Marlin 1.1.5 firmware (upgrade to your Marlin 1.1.6).
You may have to use a high quality cable or the shortest cable you can find to re-flash the board at 250000
This is the default firmware configurations I use to help get Hictop users running again.

Marlin 1.1.6

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Posted: October 11th, 2017, 10:00 am
by syadnom
Actually, I did change this to 115200