Firmware Marlin-1.1.0-RC6 - My Latest Version

Software and Firmware Discussion - related to source code, firmware updates, etc.
RyanE
Posts: 1
Joined: January 9th, 2017, 10:52 am
3D Printer(s): HicTop 3DP12

Re: Firmware Marlin-1.1.0-RC6 - now running

Postby RyanE » January 9th, 2017, 11:01 am

boomhaeur wrote:
Hey Chip,

Having the same issue... from my measurements I have the 8mm x 1.25mm threaded rod (what came with the kit) which would require 2560. I've adjusted it to the correct number (and even taken it up as high as 4000), and it seems to make no difference, I still have about a 3-4mm gap between the bed and the nozzle.

Am I missing something? Is there another variable I should be adjusting or possible issue afoot?

I have the auto-level version if that makes any difference & the nozzle level was functioning correctly on the stock firmware when I first set it up. It auto homes fine and has the right height of the bed when auto-homed.

Appreciate any thoughts you might have.


boomhaeur: Take a look at the #define Z_PROBE_OFFSET_FROM_EXTRUDER value. It will vary based on how far above your extruder your sensor is mounted. Mine is currently set to -0.7 based on my setup.

I have noticed, though, that the sensor that comes with the 3DP12 does vary by a few tenths of a mm, which is not good. I am wondering if it is due to the fact that the sensor is only powered by a 5V source when the datasheet lists the minimum voltage as 6V. Has anyone tried hooking the sensor up to 12v/24V and using a voltage divider on the output to get it back to 5V? I had a capacitive sensor on my last printer that was powered by 12V and it was much more accurate.

--Ryan

boomhaeur
Posts: 3
Joined: January 8th, 2017, 3:26 pm
3D Printer(s): HIC TOP Desktop

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Postby boomhaeur » January 10th, 2017, 2:38 pm

Thanks... have played with the setting (between -5 & +5) and doesn't seem to make any difference.

I'm wondering if I've missed something when trying to enable the auto-levelling in the script. (it's not even going down to the point where the light kicks on for it)

boomhaeur
Posts: 3
Joined: January 8th, 2017, 3:26 pm
3D Printer(s): HIC TOP Desktop

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Postby boomhaeur » January 10th, 2017, 3:23 pm

Actually RyanE you were on the right track... I'd missed un-commenting a couple of lines in the auto-leveling section and once I did that your suggestion seems to have started taking effect although now I think I've got a z-axis calibration issue as 1mm seems to move almost a cm on each increment.

Update: I have no idea why but my stock threaded rod/motor combination wanted ~350 as a steps/mm. As soon as I dialed that in, then got the auto-level functions set right things started working just right. SD card was giving me some grief but printing from USB via Pronterface has things coming out beautifully.

IronKane
Posts: 1
Joined: January 30th, 2017, 6:32 pm
3D Printer(s): Hictop 3DP-17

Re: Firmware Marlin-1.1.0-RC6 - My Latest Version

Postby IronKane » January 30th, 2017, 6:58 pm

First off, thank you Chip. Having compilable firmware for my Hictop 3DP-17 is a life saver.

I am another one with a whacked out Z steps per unit. It's like it's using CM instead of MM. I set it to 400 and uploaded it and it was close. It was dragging through the previous layer now a little bit, but it was way better than being several mm above the bed. Setting the steps for Z to 450 seems to have it dialed in. I would set my zero and using my dial calipers as a depth gauge, I noted the distance between the bed and the top of the extruder stepper. I then sent a G1 Z0.35, measured the new gap and subtracted the difference. I was able to get it to within 0.03mm.

This is great, but it's WAY too illogical!!! It should be around the 2560 value, not a 2,110 step difference! Is there some other parameter/variable that could account for this weird discrepancy?


Return to “Software and Firmware Discussion”

Who is online

Users browsing this forum: No registered users and 3 guests