How to Attach Photos

Have a suggestion for the forum? Requests? Please share
User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

How to Attach Photos

Post by LePaul » February 11th, 2016, 11:42 pm

Inserting a picture is different that most of the forum software packages out there.

However, it is pretty easy and I have made plenty of space available on the server for local storage.

First, if you are making a new post, you are in the "Full Editor and Preview" editor. If you are replying in the Quick Reply, you need to click "Full Editor and Preview" This is where, at the bottom of the screen, is the "Options", "Attachments" and "Poll Creation" tabs.
Capture.JPG
Capture.JPG (17.15 KiB) Viewed 2675 times
Click the "Attachments" and you will see the "Add File"
Capture2.JPG
The file box will appear on your computer screen and ask where the file is you wish to attach.

Once the file has been uploaded, you will see the filename, an option to "Place inline", "Delete File", "File Comment", "Size" and "Status"

Filename is self-explanatory
"Place inline" will place the link to the attachment in the body of your post
"Delete file" deletes the file you uploaded
"Size" shows you the size of your file
"Status", if Green, means the file was received and is OK.
Capture3.JPG
From here you can click the "Options" tab if there are any items you wish to check off, such as 'Notify me when a reply is posted'

You can also click "Preview" to see how the attachments look prior to hitting "Submit" to post.

That's it!

User avatar
Chip Luck
Reactions:
Posts: 191
Joined: February 11th, 2016, 9:12 am
Location: Central Florida
3D Printer(s): HICTOP Reprap Prusa I3
Contact:

Re: How to Attach Photos

Post by Chip Luck » February 25th, 2016, 9:31 am

Looks like I still cannot get photos to post to message. They do upload, but I never get the STATUS green or Place Inline tab option. Is there a maximum size?

Cheers,

Chip

User avatar
Amedee
Reactions:
Posts: 599
Joined: February 15th, 2016, 11:10 am
Location: Brussels, Belgium
3D Printer(s): UMO / UMO+
Contact:

Re: How to Attach Photos

Post by Amedee » February 25th, 2016, 10:12 am

If the file is too big it will tell you upfront.

Which browser are you using?

(Internet explorer not a good answer :roll: )
Phil.

User avatar
Chip Luck
Reactions:
Posts: 191
Joined: February 11th, 2016, 9:12 am
Location: Central Florida
3D Printer(s): HICTOP Reprap Prusa I3
Contact:

Re: How to Attach Photos

Post by Chip Luck » February 25th, 2016, 10:15 am

Firefox - latest version. Win7 64bit Ultimate. Have no issues on other sites/forums. I used to run this forum software years ago, at least I'm glad it's still around.

IE are you kidding me? Actually I boot into Ubuntu Linux most of the time for development work, hate Winblows...

Chip

===
Last edited by Chip Luck on February 25th, 2016, 10:17 am, edited 1 time in total.

User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: How to Attach Photos

Post by LePaul » February 25th, 2016, 10:16 am

Size limit is 5mb per file...which is petty darn huge for an image file.

Best success with anything non Microsoft. Firefox, Chrome or if you like Peppermint (Linux) as i do, Chromium works nicely

User avatar
Chip Luck
Reactions:
Posts: 191
Joined: February 11th, 2016, 9:12 am
Location: Central Florida
3D Printer(s): HICTOP Reprap Prusa I3
Contact:

Re: How to Attach Photos

Post by Chip Luck » February 25th, 2016, 10:19 am

As mentioned, I dual boot into Ubuntu Linux that I use for all my development work. Winblow's should still work as I have no issues with other boards/forums. I checked the file sizes and they are under 5mb, but the uploader should warn of too large a size I would assume?

Will clear cache's and Firefox and try again...

---

User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: How to Attach Photos

Post by LePaul » February 25th, 2016, 10:23 am

Please let us know...there's tons of pictures uploaded here, so it should work without much hassle

User avatar
Amedee
Reactions:
Posts: 599
Joined: February 15th, 2016, 11:10 am
Location: Brussels, Belgium
3D Printer(s): UMO / UMO+
Contact:

Re: How to Attach Photos

Post by Amedee » February 25th, 2016, 10:23 am

Very strange, I tried here to upload bad things (too big, wrong extensions, ...) and either it works or it tells you it is not valid...

Any suspicious plugin (ad-blocker, ...) or anti-virus in place?
Phil.

User avatar
Chip Luck
Reactions:
Posts: 191
Joined: February 11th, 2016, 9:12 am
Location: Central Florida
3D Printer(s): HICTOP Reprap Prusa I3
Contact:

Re: How to Attach Photos

Post by Chip Luck » February 25th, 2016, 10:40 am

The status bar goes all the way to full green during upload of a 1.4mb .jpg. Then it just sits there, not status light and no post in-line. I also tried dragging the file to message - it uploads, but then again once the status bar is done 'uploading' it just sits there. Interesting.

Of course I have anti-virus, should have nothing to do with upload of a image file. Again, other forums = no problem. Also cleared out Firefox and this sites cookies, cache, et all. Still same issue.

User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: How to Attach Photos

Post by LePaul » February 25th, 2016, 10:48 am

Testing.
test.png

User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: How to Attach Photos

Post by LePaul » February 25th, 2016, 10:57 am

I am unable to duplicate the error you are having

User avatar
martin-bienz
Reactions:
Posts: 172
Joined: February 22nd, 2016, 2:42 am
Location: Switzerland
3D Printer(s): Ultimaker Original, prusa i3 mk2

Re: How to Attach Photos

Post by martin-bienz » February 25th, 2016, 11:00 am

I had the same issue yesterday when I tried to upload the 2.4MB Original UM (cutout) of yours, so I zipp'd it and all was ok. I just thought that maybe 2.4 MB was to large... maybe try another, shorter name? Was it a png? My File was a png... maybe something to do with the mime type?

User avatar
Amedee
Reactions:
Posts: 599
Joined: February 15th, 2016, 11:10 am
Location: Brussels, Belgium
3D Printer(s): UMO / UMO+
Contact:

Re: How to Attach Photos

Post by Amedee » February 25th, 2016, 11:05 am

Chip Luck wrote:Of course I have anti-virus, should have nothing to do with upload of a image file.
No it should not...
... but some are very invasive and filter all your http content.
I used to run a relative big forum and I got the case once where some scripts were not running, and the anti-virus was the culprit...

So my questions/suggestions may seem stupid, but I have really seen a lot of edge cases...

I can myself load files up to 5M, without issues -- takes just a few seconds.

If you have a bit of experience with the "Developper's panel" from Firefox, you can check what happens with the upload on your side.
Screen Shot 2016-02-25 at 16.59.31.png
As you can see it is just a JSON POST request with the file in the payload -- there is no black magic it is posted in a single call. It would be interesting to see if that call finishes on your side or exits / times out with an error.
Phil.

User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: How to Attach Photos

Post by LePaul » February 25th, 2016, 11:08 am

martin-bienz wrote:I had the same issue yesterday when I tried to upload the 2.4MB Original UM (cutout) of yours, so I zipp'd it and all was ok. I just thought that maybe 2.4 MB was to large... maybe try another, shorter name? Was it a png? My File was a png... maybe something to do with the mime type?
I'll check the attachment extensions now

User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: How to Attach Photos

Post by LePaul » February 25th, 2016, 11:10 am

Ok, no issue on the phpBB, the image settings know GIF, JPG, PNG, JPEG, TGA, TIF and TIFF are image formats.

Post Reply

Return to “Feedback, suggestions and more”

Who is online

Users browsing this forum: No registered users and 1 guest