3.2 Beta is out!

Discussion of Ultimaker's open-source Cura software
User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

3.2 Beta is out!

Post by LePaul » January 23rd, 2018, 1:47 pm


User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: 3.2 Beta is out!

Post by LePaul » January 24th, 2018, 9:13 am

I haven't downloaded it yet....curious how my antivirus will handle it :)

GrueMaster
Reactions:
Posts: 300
Joined: March 15th, 2017, 8:46 pm
Location: Oregon
3D Printer(s): Hictop 3DP-17, Hictop CR-10S

Re: 3.2 Beta is out!

Post by GrueMaster » January 24th, 2018, 9:44 am

It still bombs out at the same point - changing the color for my Aqua Blue Glow filament to a light blue color. No idea why. Other filaments can accept that color. Very weird.

And yes, I have a bug filed on this since 2.6.

User avatar
Roberts_Clif
Reactions:
Posts: 377
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: 3.2 Beta is out!

Post by Roberts_Clif » January 24th, 2018, 10:58 am

I download Cura 3.2 and my Avast did not like it but I told it to except it, added it to the exceptions list of Avast.

The First print I tried was a Pop Bottle Bird Feeder using the Tree Support. It starting looking strange so I stopped it to learn more about the setup.
Pop Bottle Feeder 1.jpg
Pop BOttle Feeder.jpg
It started printing what looks like a upside down tree branches on the hotbed trunks in the air. Trunks stopped at the Base where the Birds stand around the perch ring.

Layer10
Layer 10.jpg

Layer20
Layer 20.jpg

Layer33
Layer 33.jpg
Any way I am a little confused. I thought the Tree would work from the base to the Supported area branches on top.
So I will relook at my settings to see where the tree got inverted. And see why it is trying to support air.

I ran a repair on the Bird feeder STL with no luck, Tree support still upside down.

STL file was so large placed it in google Drive here is link
Electronics Technician / Computer Programmer

Sometimes the correct answer if not essential to a solution.
If the information provided indirectly leads you to a solution.

User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: 3.2 Beta is out!

Post by LePaul » January 24th, 2018, 12:48 pm

Good questions for @nallath

User avatar
Roberts_Clif
Reactions:
Posts: 377
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: 3.2 Beta is out!

Post by Roberts_Clif » January 24th, 2018, 3:29 pm

LePaul wrote:
January 24th, 2018, 12:48 pm
Good questions for @nallath
Is this how to use @nallath and does is tell him we did it.
Electronics Technician / Computer Programmer

Sometimes the correct answer if not essential to a solution.
If the information provided indirectly leads you to a solution.

User avatar
Roberts_Clif
Reactions:
Posts: 377
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: 3.2 Beta is out!

Post by Roberts_Clif » January 24th, 2018, 4:52 pm

@LePaul How do I report errors to Cura 3.2.Beta.

I Can "connected to OctoPrint on red-octopi.ect..." and set temperatures thou can not send sliced model to OctoPrint.
I have a Pi Zero every thing works with Cura 3.1.0 of course I am testing tree in Cura 3.2 and find this.
Will upload sliced model directly from desktop to octoprint bypassing Cura 3.2.
Electronics Technician / Computer Programmer

Sometimes the correct answer if not essential to a solution.
If the information provided indirectly leads you to a solution.

User avatar
LePaul
Reactions:
Posts: 3099
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker 2+, FT-5, CR-10, CR-10S, Tevo Tornado
Contact:

Re: 3.2 Beta is out!

Post by LePaul » January 24th, 2018, 5:11 pm

On the Ultimaker forums. But @nallath works there and is in the dev team. So it’s convenient to mention things to him too

User avatar
Roberts_Clif
Reactions:
Posts: 377
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: 3.2 Beta is out!

Post by Roberts_Clif » January 24th, 2018, 7:24 pm

I printed the 2nd Model using the support Tree. And discovered the the trunks are big cypress trees and the branches are very tiny.
In fact some did not reach the surface area they were suppose to support, learning the support Tree will be an interesting learning experience.
Electronics Technician / Computer Programmer

Sometimes the correct answer if not essential to a solution.
If the information provided indirectly leads you to a solution.

GrueMaster
Reactions:
Posts: 300
Joined: March 15th, 2017, 8:46 pm
Location: Oregon
3D Printer(s): Hictop 3DP-17, Hictop CR-10S

Re: 3.2 Beta is out!

Post by GrueMaster » January 25th, 2018, 1:07 am

As with 3.1, it doesn't transfer all of my settings. Really do not want to have to reconfigure my printers each time I upgrade. There is nothing to change.

I'll have to deep dive into my configs to figure out why it only transfers 1 printer (little-hicci) and still fails to change the color of one filament entry (I can change the rest to the same color, so it is some sort of config corruption).

nallath
Reactions:
Posts: 265
Joined: February 16th, 2016, 3:12 am
3D Printer(s): Ultimaker

Re: 3.2 Beta is out!

Post by nallath » January 25th, 2018, 8:11 am

GrueMaster wrote:
January 24th, 2018, 9:44 am
It still bombs out at the same point - changing the color for my Aqua Blue Glow filament to a light blue color. No idea why. Other filaments can accept that color. Very weird.

And yes, I have a bug filed on this since 2.6.
Could you post the logs? I'm not directly on the Cura team anymore, but i might be able to see some obvious issue that I can fix in no-time.

As for the tree support, i know very little about it. I had almost nothing to do with the development of that feature.

User avatar
Roberts_Clif
Reactions:
Posts: 377
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: 3.2 Beta is out!

Post by Roberts_Clif » January 25th, 2018, 9:10 am

The tree function is not the issue it is just a learning curve.
The 3D Printer connection with Cura 3.2 I can see the temperature change and control the steppers just can not send a model to octoprint.

Today I will try to re-install Cura 3.2 see if it missed some files.
Electronics Technician / Computer Programmer

Sometimes the correct answer if not essential to a solution.
If the information provided indirectly leads you to a solution.

GrueMaster
Reactions:
Posts: 300
Joined: March 15th, 2017, 8:46 pm
Location: Oregon
3D Printer(s): Hictop 3DP-17, Hictop CR-10S

Re: 3.2 Beta is out!

Post by GrueMaster » January 25th, 2018, 9:47 am

@nallath The bug is posted here. I also updated with some new information last night.

User avatar
Roberts_Clif
Reactions:
Posts: 377
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: 3.2 Beta is out!

Post by Roberts_Clif » January 25th, 2018, 8:55 pm

I definitely want Cura 3.2 features.
Testing can still be done but not with my current configuration thru a direct connection from Cura 3.2 Beta to Octoprint.
Will slice the model save g-code to PC then upload to OcotPrint and print or simple save to 3D Printer SD Card.
Electronics Technician / Computer Programmer

Sometimes the correct answer if not essential to a solution.
If the information provided indirectly leads you to a solution.

User avatar
Roberts_Clif
Reactions:
Posts: 377
Joined: March 25th, 2017, 8:17 am
Location: Washington
3D Printer(s): Hictop 3DP11/12

Re: 3.2 Beta is out!

Post by Roberts_Clif » January 29th, 2018, 11:47 am

OctoPrintPlugin.curaplugin

I was trying to install Cura 3.2 as wanted to play with the new Tree Support, Well the Tree support looks promising though it will have a learning curve to get familiar with.

I am having trouble with making OctoPrint Cura's pluggin to work. It will allow me to control the 3D printer Home commands, and it will allow me to see the Printer on OctoPrint web cam ect...
What it will not allow me to do is to complete the G-Code send, Watch the video when you click on the large Blue "Print With OcotPrint" button. It appears to send the data. but does not complete the action.

The only other item that does not works is, cannot setup two OctoPrint to print in a single instance of Cura 3.2 Beta.
If I try to save an API code to the Second Printer will over write the first.

Attached Video of test.
Electronics Technician / Computer Programmer

Sometimes the correct answer if not essential to a solution.
If the information provided indirectly leads you to a solution.

Post Reply

Return to “Cura”

Who is online

Users browsing this forum: No registered users and 3 guests