2.3 beta

Discussion of Ultimaker's open-source Cura software
nallath
Posts: 150
Joined: February 16th, 2016, 3:12 am
3D Printer(s): Ultimaker

2.3 beta

Postby nallath » September 1st, 2016, 11:22 am

Yay -> https://ultimaker.com/en/products/cura-software

There is no linux or win 32 build, because our build server decided to kill itself. We will release those next week. Let me know what you guys think.

User avatar
LePaul
Posts: 1898
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker Original, Ultimaker 2
Contact:

Re: 2.3 beta

Postby LePaul » September 1st, 2016, 12:18 pm

I'll take a look and download....is there a public change log?

johan
Posts: 23
Joined: February 13th, 2016, 9:12 am
3D Printer(s): UMO (UM2, UM2+, UM2XT+, Form2, etc. at work)

Re: 2.3 beta

Postby johan » September 1st, 2016, 12:36 pm

There is a blog post change log: https://ultimaker.com/en/blog/22320-cur ... ta-is-here

It's quite impressive.

User avatar
LePaul
Posts: 1898
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker Original, Ultimaker 2
Contact:

Re: 2.3 beta

Postby LePaul » September 1st, 2016, 1:05 pm

It is, thanks! I never think to look at the blog

User avatar
Meduza
Posts: 238
Joined: February 10th, 2016, 8:08 pm
Location: Stockholm, Sweden
3D Printer(s): UM2+, F1+ at home (F2, UM2EX+, etc at work)
Contact:

Re: 2.3 beta

Postby Meduza » September 1st, 2016, 1:09 pm

Be sure to check out the "Infill mesh" feature, it is not mentioned in the blog post, but is a pretty cool mode! :)

User avatar
LePaul
Posts: 1898
Joined: February 7th, 2016, 10:26 pm
Location: Bangor, Maine USA
3D Printer(s): Ultimaker Original, Ultimaker 2
Contact:

Re: 2.3 beta

Postby LePaul » September 1st, 2016, 1:13 pm

Two quick questions after install...

1) What's the top right? I thought some tags might appear as I hover over them

2) How can I make Dual Extrusion go away? In Settings, I do not see a check box to remove it

User avatar
drayson
Posts: 204
Joined: February 15th, 2016, 5:04 am
Location: Graz, Austria
3D Printer(s): UMO with mods :-)

Re: 2.3 beta

Postby drayson » September 1st, 2016, 2:38 pm

Höööö.... simply jump over 2.2 :-) great...
Hope it is compartible with the settings out of 2.1.x ;-) (nallath, I guess you know what I mean...)

Guys, if somebody is interested, I modified my excel material data file to write the new material profile files for easy import...
I will check if it´s working with 2.3 too and post it later...

User avatar
drayson
Posts: 204
Joined: February 15th, 2016, 5:04 am
Location: Graz, Austria
3D Printer(s): UMO with mods :-)

Re: 2.3 beta

Postby drayson » September 1st, 2016, 3:39 pm

Checked, it works...

Please find attached the Material file generator excel. Maybe usefull for somebody.... :-)

Important: on the first table place your material print information. the parser table is just for combining, so nothing to change there, the color table is just for assistance if somebody like to set a specific color (just 256 in :-( ).

I already included some material data so it should be easy to extend it.
File export is done via selecting the material in C2 and press export. The exported file is placed in the same directory as the excel is places.

As I already mentioned, maybe usefull as the new material library is AWSOME !!!
Attachments
_Material Data_Cura2.3.xlsm
(48 KiB) Downloaded 12 times

User avatar
Dim3nsioneer
Posts: 202
Joined: February 19th, 2016, 2:13 pm
Location: Zurich Area, Switzerland
3D Printer(s): Ultimaker Original, Ultimaker 2, Ultimaker 3
Contact:

Re: 2.3 beta

Postby Dim3nsioneer » September 1st, 2016, 3:47 pm

Uhm... found a no-go.
No TweakAtZ.
:cry:

User avatar
drayson
Posts: 204
Joined: February 15th, 2016, 5:04 am
Location: Graz, Austria
3D Printer(s): UMO with mods :-)

Re: 2.3 beta

Postby drayson » September 1st, 2016, 4:32 pm

Strage - I have TweakAtZ 5.1 in...

But the ShowLayer plugin which shows the layer number at the ulticontroller is not working - even the already modified version from Amedee...

User avatar
Dim3nsioneer
Posts: 202
Joined: February 19th, 2016, 2:13 pm
Location: Zurich Area, Switzerland
3D Printer(s): Ultimaker Original, Ultimaker 2, Ultimaker 3
Contact:

Re: 2.3 beta

Postby Dim3nsioneer » September 2nd, 2016, 1:12 am

drayson wrote:Strage - I have TweakAtZ 5.1 in...


Oops - you're right... :oops:
@nallath: The open-change-value-on-ticking-option functionality seems to have gone. All inputs are visible even if no checkbox is ticked.

nallath
Posts: 150
Joined: February 16th, 2016, 3:12 am
3D Printer(s): Ultimaker

Re: 2.3 beta

Postby nallath » September 2nd, 2016, 3:34 am

@Dim3nsioneer Ugh. Damnit. I'll have a look. Thank god we do beta's these day instead of releasing right away.

*EDIT*

Aand fixed. https://github.com/nallath/PostProcessi ... ea3a45067e

User avatar
martin-bienz
Posts: 168
Joined: February 22nd, 2016, 2:42 am
Location: Switzerland
3D Printer(s): Ultimaker Original, prusa i3 mk2

Re: 2.3 beta

Postby martin-bienz » September 2nd, 2016, 4:31 am

Hi Guys, nallath,
I am really impressed by the speed improovements, rendering speed of the layers! Great work, well done.

I just tested a few things and had to start fresh (deleted the old cura profiles, settings) as it generated some wierd behaviour with profiles coming from 2.1.2.

Great to see that the machine profile is improved! Especially from UMO Users :).

1. When you create a new profile with UMO and select "Have HBK", the Temp for HB settings does not activate. After going to Machine Settings and enabling the HB again, it works. Tried twice.
2. If you group objects, the layer - view produces strange things, see attached picture. top is grouped, bottom is ungrouped.
group.PNG


Thanks!

Martin

nallath
Posts: 150
Joined: February 16th, 2016, 3:12 am
3D Printer(s): Ultimaker

Re: 2.3 beta

Postby nallath » September 2nd, 2016, 5:49 am

@martin-bienz
I can't reproduce the layerview issue. On what OS are you doing this? Could you send me your logs as well?
I have been able to reproduce the heated build plate issue. Will put it in the issue tracker.

johan
Posts: 23
Joined: February 13th, 2016, 9:12 am
3D Printer(s): UMO (UM2, UM2+, UM2XT+, Form2, etc. at work)

Re: 2.3 beta

Postby johan » September 2nd, 2016, 7:21 am

@nallath: I think it's an issue with the lack of transparency in OpenGL. Related to the ghosts.


Return to “Cura”

Who is online

Users browsing this forum: No registered users and 1 guest